Sunday, September 16, 2012

Neocom on iOS 5

I think for a long time to move Neocom on iOS 5. But then the application can not be run on older devices (iPhone 3G, iPod 2G). I can not see the statistics of the devices used. I was wondering your opinion, how this update would be appropriate.

13 comments:

  1. Love the app ... but aren't all the devices that can just about to be upgraded to iOS6 ?

    ReplyDelete
    Replies
    1. All iPad devices, iPhone 3GS and newer, iPod Touch (4th generation) can be updated to iOS 5.

      Delete
  2. Maybe leave an old version as a legacy version... Stalled in development but still usable on older devices.

    ReplyDelete
  3. Go for IOS6, unless IOS5 has no feature limitations :)

    Btw, kudos for making this app! :)

    ReplyDelete
  4. Do you think you can make an android app? This app is far superior to the app for the android. I'm sure there is a lot of people out there that would be willing to compensate you monetarily for such an app. I know I would.

    ReplyDelete
  5. You can build for the current iOS version but set the build target to the lowest version you want to build for to ensure backwards compatibility. If you use any new features that are only available in a new iOS you will need to weak link the newer features (or use some other method) so they will only be loaded on hardware/software that supports them.

    What you can't do now though is build for iOS 6 and have it run on older devices like the iPhone 3G, since the new version of XCode (which is required to build for iOS 6) won't build for the armv6 hardware the older devices have.

    All that said, it seems to be running fine on iOS 6 as it is so it's only worth updating if there are specific features introduced in iOS 5 or 6 that you want to use.

    ReplyDelete
    Replies
    1. All problems in new XCode. XCode 4.5 not support armv6, so, all devices prior to iPhone 3GS will not run Neocom. Currently i need 2 versions of XCode for Neocom and for my other work.

      Delete
  6. I would say hold off until you absolutely need to update to a new iOS. The mode older devices you support the better.

    ReplyDelete
  7. Hi there
    Cant you do a "lite" for current and backward compapility and a version 6 for Iphone and Ipad.
    This is the #1 program for my eve (thats why i donate on every device i use it on - support the good programs out there all).
    I´d use both as the lite wont take much traffic over air when not near wi-fi and the ver. 6 is when i nerd my thingies at a wi-fi location.

    ReplyDelete
  8. Love the program, use it everyday. I also donate for every device I put it on.

    A request: could you add a kill-mail feature?

    ReplyDelete
  9. I'd love to see a version that takes advantage of the iPhone 5's larger screen.

    ReplyDelete
  10. Apple sucks :)
    Ive got a 4S, not by choice, but of my boss, so i don't complain. As to the app: i love it. I wont upgrade to ios6 unless eventually necessary (apple will find a way). So i'd be glad if the app would work for another while on ios 5.x

    ReplyDelete
  11. I know it is of topic for your question. But I have been using your app for a long time both on iPhone and iPad and donated on both. You app is the best around.
    I have recently moved to a WinPhone 8 and will soon change my iPad to a WindowsRT device as well and you should seriously consider porting your App to Win-platform as well. There are some EVE Apps available, but none with the quality of Neocom, so you have a chance to take that platform completely by storm.

    ReplyDelete